Support

Forum Navigation
You need to log in to create posts and topics.

More-Lang and WPBakery Page Builder

Hi,

I've found that if the plug-in is active, I can't edit the backend of the page with my page builder (in my case WPBakery).

This is the video that shows the problem: https://youtu.be/D9qztedIWDA

You can see that if I deactivate more-lang, the page builder starts working as expected, but it does not if More-Lang is active.

Thank you

Hello,

    More-Lang doesn't support the WPBakery page builder, and because it has not a free downloadable version, currently I can't check it.

   Since you have More-Lang Pro installed, actually you can try the following solution:

   There is an option labeled "Do not add More-Lang fields to the Post editor when", you can set the values expected. If "the Post Type is in" is not appropriate, you can set "one of the Taxonomy Terms is in"(Taxonomy means Categories, Tags, etc. E.g.,  you can add a Tag value "no_morelang_fields", put it in the option, and assign it to the Posts which will use WPBakery page builder,  then, More-Lang fields will hide, and will not disturb WPBakery page builder)

Thanks!

Thank you,

I've found the reason, when I clicked on Edit page, WP was taking me to the non default language tab of the classic editor  for some reason (0:19 in the video). Wich was obviously empty.

Hi giessedati,

   So, does the WPBakery page builder work normally now?

Regards!

Hi,

yes it does seem to work now, I haven't had any particular issue since then.

Please, can you take a look at my other request?

Thank you

Hi giessedati,

   Sorry, I was busy on the next release of More-Lang, and neglected your another issue.

Hi,

I've found that sometimes the modifications are not saved anyway, I'm still debuggin it but if I deactivate the plugin it works normally. So I wanted to add taxonomy to a page to exclude More-Lang but it's not possible, as tags are available only for articles.

I've found that I can set "the Post Type is in: Page" as basically every page will also be in URI-map, but how should I do if I wanted to exclude More-Lang only from some page?

Thank you

Hi giessedati,

By default, taxonomies are disabled for Page, but they can be enabled by coding, e.g., you can add the following code to the functions.php to enable tags:

function my_add_taxonomy_to_pages() {
/* Change 'post_tag' to 'category' if Category is required */
register_taxonomy_for_object_type( 'post_tag', 'page' );
}
add_action( 'init', 'my_add_taxonomy_to_pages' );

If you would not like to add code, you can also use some plugins, such as: https://wordpress.org/plugins/tag-pages/.

Regards!

 


CONTACT: